czekaj...
Loguję...
Ładuję
Excel - Sumowanie po wielu kryteriach SUMA.JEŻELI i SUMA.WARUNKÓW - pytania widzów #4

Dodane przez: Adam Kopeć, 02 maja 2013r.
Autor: Adam Kopeć
Kategoria: Informatyka
Licencja:


Głosów: 0
2424
Darmowy Kurs Excel 2010 podstawy http://exceliadam.pl/darmowy-kurs Excel - Sumowanie po wielu kryteriach SUMA.JEŻELI i SUMA.WARUNKÓW - pytania widzów #4 http://ExceliAdam.pl/ Roman miał tabelę z hurtowniami i ich zarobkami uporządkowanymi według dat. Robił sumę zysków dla poszczególnym hurtowni wykorzystując funkcję SUMA.JEŻELI. Jego funkcja miała taką strukturę: SUMA.JEŻELI(Zakres z nazwami hurtowni; Nazwa hurtowni po której chce sumować; Zakres po którym będzie sumowane po sprawdzeniu warunków) Ta struktura przekłada się na filmie w odwołania do odpowiednich komórek SUMA.JEŻELI(D3:D14;I2;E3:E14) Ta funkcja sprawdzała się, gdy chciał sumować po jednym warunku (nazwie hurtowni), ale gdy zaszła potrzeba do tego dołożyć jeszcze daty, ta formuła nie dawała rady. Należało wykorzystać funkcję SUMA.WARUNKÓW. Ta funkcja pozwala na ustawienie wielu warunków jednocześnie. Struktura funkcji SUMA.WARUNKÓW pozwala na ustawienie wielu warunków, zawsze ustawianych w pary z zakresami, to znaczy, że 1 parametrem funkcji jest zakres, po którym będzie liczona suma, a następnie podajesz parę: - zakres po którym sprawdzany ma być warunek, - warunek Te dwa parametry zawsze muszą być podawane w parze, a takich par możesz dodać bardzo dużo. Przykładowy zapis dla sprawdzenia nazwy hurtowni i ustawienia daty pomiędzy 2012-11-01, a 2012-10-01 wygląda tak (YT nie pozwala na zamieszczanie w tekście znaków mniejszości i większości, zastąpiłem je odpowiednio znakami @# i #@) =SUMA.WARUNKÓW(E3:E14;D3:D14;I2;B3:B14;"@#2012-11-01";B3:B14;"#@2012-10-01") 1 parametr (E3:E14) to zakres, po którym będzie robiona suma, 2 parametr (D3:D14) to zakres, po którym będzie sprawdzany 1 warunek (nazwa hurtowni), 3 parametr (I2) to nazwa hurtowni, po którym będzie sprawdzany 1 zakres, 4 parametr (B3:B14) to zakres, po którym będzie sprawdzany 2 warunek (mniejsze od daty, czyli wcześniej niż data), 5 parametr ("@#2012-11-01") to odpowiednio znak mniejszości i data w cudzysłowie, po której będzie przeszukiwany 2 zakres, 6 parametr (B3:B14) to zakres, po którym będzie sprawdzany 3 warunek (mniejsze od daty, czyli wcześniej niż data), 7 parametr ("#@2012-10-01") to odpowiednio znak mniejszości i data w cudzysłowie, po której będzie przeszukiwany 3 zakres, W podobny sposób możesz dodawać kolejne warunki - zawsze w parach - zakres_sprawdzania_warunku i warunek Możesz zauważyć, że w przykładzie powyżej 3 parametr jest zapisany jako odwołanie do komórki, a 5 i 7 parametr są wpisane z cudzysłowach. Jeżeli chciałbyś, żeby były one pokazane jako odwołania do komórek powinny wyglądać odpowiednio tak: "@#"&J6 i "#@"&J7 czyli połączenie (&) znaku mniejsze lub większe w cudzysłowie z odwołaniem do komórki Cała formuła wtedy wygląda odpowiednio: =SUMA.WARUNKÓW(E3:E14;D3:D14;I2;B3:B14;"@#"&J6;B3:B14;"#@"&J7) Excel - Sumowanie po wielu kryteriach SUMA.JEŻELI i SUMA.WARUNKÓW - pytania widzów #4 http://youtu.be/EPC5k1Zv7Po
 

Udostępnij
Pokaż komentarze (0)  


Sprawdź też inne szkolenia:
Partnerzy:
cyfrowynauczyciel.pl
rozwojowiec.pl
wszechnica.org.pl
  Publikujemy na licencji Creative Commons CC
 
 
Innowacyjna Gospodarka
PARP
Unia Europejska
 
 
 
Projekt współfinansowany ze środków Unii Europejskiej w ramach Europejskiego Funduszu Rozwoju Regionalnego

Dotacje na innowacje - Inwestujemy w Waszą przyszłość