czekaj...
Loguję...
Ładuję
Excel - Poprawność danych dla 2 kolumn jednocześnie - sztuczki #7

Dodane przez: Adam Kopeć, 02 maja 2013r.
Autor: Adam Kopeć
Kategoria: Informatyka
Licencja:


Głosów: 0
2128
Darmowy Kurs Excel 2010 podstawy http://exceliadam.pl/darmowy-kurs Excel - Poprawność danych dla 2 kolumn jednocześnie - sztuczki #7 http://ExceliAdam.pl/ Poprawność danych to bardzo ciekawa opcja w Excelu. Możesz sprawić np: że na danym obszarze będzie można wpisywać tylko liczby, pozycje z zadeklarowanej listy i etc. Poprawność danych jest tak potężna, że możesz nawet nałożyć na 2 kolumny jednocześnie. Potrzebujesz do tego odpowiedniej funkcji. Najpierw zaznaczasz obszar (w tym przykładzie to A2:B13), który chcesz, żeby był poddawany sprawdzeniu poprawności danych. Następnie przejdź na zakładkę Data i wybierz opcję Poprawność danych. Pojawi Ci się okno, z którego wybierasz wartości dozwolone. Żeby sprawdzać poprawność danych dla 2 kolumn potrzeba ten parametr ustawić na Niestandardowy, a następnie wpisać formułę: =SUMA(JEŻELI($A$2:$A$13&$B$2:$B$13=$A2&$B2;1;0))=1 Teraz jeśli będziesz chciał wpisać osobę o tym samym imieniu i nazwisku Excel wyświetli Ci komunikat, że możliwość wpisania danych została ograniczona. Teraz ważne pytanie - Jak ta formuła działa. Możesz ją sobie przetestować. Wpisując do komórki, tylko w komórce musisz nacisnąć jeszcze: Ctrl + Shift + Enter żeby dać znać Excelowi, że ma obliczać formuły tablicowe. Jeśli tego nie zrobisz wynik operacji będzie błędny. Parametr $A$2:$A$13&$B$2:$B$13 łączy imię i nazwisko z każdego wiersza następnie te wartości (dla każdego wiersza) są przyrównywane do połączonej wartości imienia i nazwiska w tym konkretnym wierszu w którym jesteś. W efekcie uzyskujesz tablicę PRAWDA i FAŁSZ. Gdzie prawda pojawia się tam, gdzie te wartości są równe do aktualnego wiersza, a fałsz gdy są różne. Dalej funkcja JEŻELI, zamienia wartość PRAWDA na 1, FAŁSZ na 0. Zawsze uzyskasz minimum jedną prawdę, ponieważ aktualny wiersz jest częścią większego obszaru. Gdy uzyskasz więcej prawd oznacza to, że wartość się powtarza w innych wierszach. Kolejnym krokiem jest sumowanie funkcją SUMA. Uzyskasz wartość 1 gdy będzie tylko jedna wartość imienia i nazwiska (w aktualnym wierszu), gdy się powtarzają będą to większe wartości. Następnie wynik funkcji SUMA jest przyrównywany do 1, czyli daje wynik PRAWDA tylko wtedy, kiedy dana wartość wystąpiła tylko w aktualnym wierszu, a jeśli się powtórzy pojawi się FAŁSZ i tym samym Excel uniemożliwi jest wpisanie. Ważne, że przy Poprawności danych niestandardowych zaznaczona jest automatycznie opcja pomijaj puste. Bo puste wiersze mogą się powtarzać. Film na podstawie newsletera nr 187 Excel w praktyce https://excelwpraktyce.pl/ Excel - Poprawność danych dla 2 kolumn jednocześnie - sztuczki #7 http://youtu.be/rZGpqO2GlZQ
 

Udostępnij
Pokaż komentarze (0)  


Sprawdź też inne szkolenia:
Partnerzy:
cyfrowynauczyciel.pl
rozwojowiec.pl
wszechnica.org.pl
  Publikujemy na licencji Creative Commons CC
 
 
Innowacyjna Gospodarka
PARP
Unia Europejska
 
 
 
Projekt współfinansowany ze środków Unii Europejskiej w ramach Europejskiego Funduszu Rozwoju Regionalnego

Dotacje na innowacje - Inwestujemy w Waszą przyszłość