czekaj...
Loguję...
Ładuję
Excel - Znajdowanie 1 z 2 fragmentów tekstu w pionowej liście - porada #51

Dodane przez: Adam Kopeć, 02 maja 2013r.
Autor: Adam Kopeć
Kategoria: Informatyka
Licencja:


Głosów: 0
4845
Darmowy Kurs Excel 2010 podstawy http://exceliadam.pl/darmowy-kurs Excel - Znajdowanie 1 z 2 fragmentów tekstu w pionowej liście - porada #51 http://ExceliAdam.pl/ Już wcześniej w poradzie 49 (http://youtu.be/KBlbwB-wyqA) mogłeś widzieć jak wyszukiwać fragment tekstu w pionowej liście. Widziałeś to na przykładzie działania funkcji WYSZUKAJ.PIONOWO. Tym razem posłuży do wyszukania 1 z 2 fragmentów tekstu, ale żeby uzyskać ten efekt potrzeba jeszcze dodatkowych funkcji i warunków. =JEŻELI( CZY.BŁĄD(WYSZUKAJ.PIONOWO("*"&C1&"*"; A1:A8; 1; FAŁSZ)); JEŻELI( CZY.BŁĄD(WYSZUKAJ.PIONOWO("*"&C2&"*";A1:A8;1;FAŁSZ)); "brak"; WYSZUKAJ.PIONOWO("*"&C2&"*";A1:A8;1;FAŁSZ)); WYSZUKAJ.PIONOWO("*"&C1&"*";A1:A8;1;FAŁSZ)) To właśnie jest przykładowy kod, który możesz wykorzystać właśnie do wyszukiwania 1 z 2 fragmentów tekstu. Cała formuła jest oparta głównie o funkcje JEŻELI i WYSZUKAJ.PIONOWO. Najpierw wchodzimy w pierwszą funkcję JEŻELI i rozpatrujemy wynik wyszukiwania. Jeśli funkcja WYSZUKAJ.PIONOWO znajdzie tekst, to tym samym, funkcja CZY.BŁĄD zwróci FAŁSZ, czyli Excel przejdzie do 3 parametru pierwszej funkcji jeżeli, czyli podstawi tam wynik wyszukiwania. Ponieważ fragment tekstu został znaleziony, to można wyszukać całość komórki z tym fragmentem. Tu należy pamiętać, że funkcja WYSZUKAJ.PIONOWO znajduje pierwszy taki fragment na liście. W sytuacji, gdyby pierwszy fragment tekstu nie został znaleziony to CZY.BŁĄD zwróci wartość PRAWDA i Excel przejdzie do drugiej (zagnieżdżonej) funkcji JEŻELI i tutaj analogicznie przebiega proces, tylko, że dla drugiego fragmentu tekstu. Jeśli nie zostanie znaleziony również ten fragment to, funkcja zwróci wartość "brak", jeśli zostanie znaleziony, to wynikiem będzie wartość komórki, gdzie po raz pierwszy został znaleziony ten fragment. Cała formuła działa tak, że jak znajdzie pierwszy fragment, to nie szuka dalej drugiego. Podobnie za każdym razem szuka pierwszego wystąpienia danego fragmentu i na tym poprzestaje. Kod formuły zaczerpnięty ze strony: http://forum.idg.pl/topic/199188-wyszukajpionowo/ Excel - Znajdowanie 1 z 2 fragmentów tekstu w pionowej liście - porada #51 http://youtu.be/jfqOMBfSj2c
 

Udostępnij
Pokaż komentarze (0)  


Sprawdź też inne szkolenia:
Partnerzy:
cyfrowynauczyciel.pl
rozwojowiec.pl
wszechnica.org.pl
  Publikujemy na licencji Creative Commons CC
 
 
Innowacyjna Gospodarka
PARP
Unia Europejska
 
 
 
Projekt współfinansowany ze środków Unii Europejskiej w ramach Europejskiego Funduszu Rozwoju Regionalnego

Dotacje na innowacje - Inwestujemy w Waszą przyszłość