czekaj...
Loguję...
Ładuję
Excel Poprawność danych - unikalne daty - porada #71

Dodane przez: Adam Kopeć, 02 maja 2013r.
Autor: Adam Kopeć
Kategoria: Informatyka
Licencja:


Głosów: 0
2999
Darmowy Kurs Excel 2010 podstawy http://exceliadam.pl/darmowy-kurs Excel Poprawność danych - unikalne daty - porada #71 http://ExceliAdam.pl/ Poprawność danych może Ci umożliwić sprawdzanie unikalności danych, czyli, czy dana data (lub dowolna inna wartość) wystąpiła tylko raz w danym obszarze. Uzyskujesz to dzięki zastosowaniu odpowiedniej formule. Jeśli jest istotne dla Ciebie, żeby formuła się przesuwała ponieważ będziesz dodawał wiersze możesz użyć tej formuły: =SUMA(JEŻELI($B$3:B3=B3;1;0))=1 Jeśli jednak wiesz, że będzie to stały obszar to lepsza okaże się ta formuła" =SUMA(JEŻELI($B$3:$B$9=B3;1;0))=1 Pierwsza rośnie wraz z obszarem, ale nie sprawdza poprawności w przód, czyli jeśli w będziesz chciał wstawić w wiersz 5 datę (wartość), która jest w wierszu 6, ta formuła Ci to umożliwi. Nie pozwoli jednak byś wpisał w wiersz 6 taką samą datę (wartość) jak w 5. Druga formuła nie pozwoli, na żadne duplikaty na zaznaczonym obszarze. Druga formuła jednak nie będzie się automatycznie powiększać wraz z dodawaniem nowych wierszy, będzie sprawdzać tylko czy szukana wartość nie wystąpiła już na przyjętym obszarze ($B$3:$B$9). Pierwsza natomiast będzie się rozrastać dzięki względnemu ustawieniu jej drugiego końca ($B$3:B3) Obie formuły, są formułami tablicowymi, więc jeśli chciałbyś je wstawić do arkusza Excela, musiałbyś je zatwierdzić kombinacją klawiszy Ctrl + Shift + Enter Przy wpisywaniu jej do warunków poprawności danych, nie musisz się tym przejmować. Excel Poprawność danych - unikalne daty - porada #71 http://youtu.be/anaKiAEdDOA
 

Udostępnij
Pokaż komentarze (0)  


Sprawdź też inne szkolenia:
Partnerzy:
cyfrowynauczyciel.pl
rozwojowiec.pl
wszechnica.org.pl
  Publikujemy na licencji Creative Commons CC
 
 
Innowacyjna Gospodarka
PARP
Unia Europejska
 
 
 
Projekt współfinansowany ze środków Unii Europejskiej w ramach Europejskiego Funduszu Rozwoju Regionalnego

Dotacje na innowacje - Inwestujemy w Waszą przyszłość